Ceci est un test servant à tester

j’ai eu un peu de mal à me mettre dans le bains et puis ça y est. En tout cas ce projet me plait bien.

Bienvenue JulietteVS !

C’est très bizarrede ne pas voire mon curseur

Bienvenu @Stephane.
As-tu trouvé un bug ? Quel OS et quel navigateur ?

Il y a deux choses quand je clique sur le forum en haut à droite.
D’abord, quelque soit l’OS/navigateur, quand je clique sur le « Ceci est un test servant à tester » j’obtiens la même chose : la liste des réponses à droite et un « Oop! That page doesn’t exist anymore ».
Ensuite, lorsque je réponds, ça dépend. Avec Ubuntu/Firefox je ne vois pas mon curseur. Par contre, je vois mon curseur avec Archlinux/qutebrowser.
Lorsque j’ai rédigé la proposition de modification du vote (Ubuntu/Firefox), je voyais mon curseur.
Lorsque j’arrive sur le site, la racine me donne toujours la page en anglais, lorsque je me connecte, j’ai le menu est en français mais la page d’accueil est en anglais. Je ne sais pas si c’est lié.

D’abord, quelque soit l’OS/navigateur, quand je clique sur le « Ceci est un test servant à tester » j’obtiens la même chose : la liste des réponses à droite et un « Oop! That page doesn’t exist anymore ».

Oui, j’avais supprimé la page. Je viens de la rétablir.

Avec Ubuntu/Firefox je ne vois pas mon curseur. Par contre, je vois mon curseur avec Archlinux/qutebrowser. Lorsque j’ai rédigé la proposition de modification du vote (Ubuntu/Firefox), je voyais mon curseur.

Je vais regarder ça.

Lorsque j’arrive sur le site, la racine me donne toujours la page en anglais, lorsque je me connecte, j’ai le menu est en français mais la page d’accueil est en anglais. Je ne sais pas si c’est lié.

2 questions :

  1. Dans quelle langue est ton navigateur ?
  2. As-tu spécifié une langue dans ton profil ? (normalement, c’est à l’adresse suivante : https://www.castafiore.org/u/stephane/preferences/interface, sinon tu peux le retrouver un cliquant sur ton avatar en haut à droite, puis sur ton pseudo, puis préférences > interface)

Là, je te réponds avec Firefox et j’ai le curseur.
Je ne sais pas si tu as fait quelque chose.

Pour Firefox, l’affichage des menus est en français et la langue des pages est d’abord français, ensuite anglais. J’avais cherché un peu en voyant que la navigation était moyenne entre le passage du français à l’anglais. Pour le profil, je l’ai indiqué : je suis en français. Mais pour me connecter faut d’abord afficher la page, il me redirige vers une page en anglais (ie : redirection d’url) et ensuite, lorsque je suis connecté, seul le menu passe en français.

Pour qutebrowser, je ne m’étais pas posé la question et j’ai vérifié. Il est en anglais, mais comme le but n’est pas d’afficher des menus, je n’ai jamais cherché à le savoir. Pour le choix de la langue, j’ai mis les mêmes préférences que pour Firefox : d’abord français puis anglais alors que je n’avais que l’anglais qui était mis par défaut. Et ça me fait arriver sur la page en français par défaut.

J’ai trouvé pour le curseur avec firefox.
Si je réponds, je n’ai pas le curseur.
Si je cite le message auquel je réponds, le curseur apparaît.
Après, je peux dégager la citation, le curseur reste.

C’est étrange. Si ton Firefox est configuré pour afficher d’abord les pages en français, c’est Castafiore en français qui devrait s’afficher par défaut (comme dans ton qutebrowser). Peux-tu stp cliquer sur https://www.castafiore.org et me confirmer que tu arrives bien sur la page anglaise ?

Ca, par contre, c’est normal. Le système ne permet pas encore de changer la langue des pages en cas de login/logout (il faut faire un rafraîchissement du navigateur (F5)). J’ai fait une demande de fonctionnalité ici à ce sujet.
Néanmoins, s’il n’y avait pas le premier problème, ce second problème ne se poserait pas…

Je sais que c’est étrange, c’est pour ça que je croyais que c’était interne et c’est pour ça que je n’avais pas cherché avant de te répondre avec qutebrowser.
Une fois connecté, par contre, le F5 ne sert à rien puisque le lien vers la page anglaise est écrit en dur dans l’url. Par contre, un clic en haut à gauche affiche la page d’accueil en français, qui est la même que pour ton lien, après connexion.

Oui, pardon pour cette histoire de F5, c’était idiot de ma part.

Pour le reste, je vais y réfléchir. Es-tu certain que ton Firefox n’est pas altéré d’une façon ou d’une autre ? (je demande parce que cette histoire de curseur paraît bizarre aussi)

Bonjour,
j’ai un souci, quand vous dites, “je mets en haut à gauche” quand une décision est prise, je ne vois pas où ça peut être “en haut à gauche”…
Merci et bonne journée
juliette

Bonjour @JulietteVS.

Pardon pour le retard.

Quand je dis : “je mets à jour dans le document à gauche”, je veux dire que je modifie la page “officielle”.

Sur ordinateur, la page “officielle” s’affiche dans la partie gauche de l’écran:

Sur mobile, elle s’affiche dans le panneau qu’on ouvre en cliquant sur la barre verticale verte:
image

J’ai peut-être un plugin qui interragit, il y a plein de trucs qui peuvent intervenir.
Ne perds pas trop de temps là-dessus, je survis et suis plus souvent sur qutebrowser que sur Firefox.
J’avais surtout besoin d’y être la première fois pour l’inscription.

1 Like